summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-05 23:02:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-05 23:10:44 +0200
commiteb9b0046f53dfd9421e8cd0579bf0b5d6ad754c7 (patch)
tree88f8fd444587413a9bd63c1773c654a2ee3efdaf
parentbd7bb4794400ee0cbffda52846f6464a5390ea5b (diff)
gnu: texlive-ps2eps: Fix Ghostscript executable name.
* gnu/packages/tex.scm (texlive-ps2eps)[arguments]<#:phases>: Use "gs" instead of "gswin32c".
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9ac9105342..8b8d98fa16 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -41683,7 +41683,19 @@ and glued together. This will lead to a physical product box.")
"1anrvgs0hd3790dwpxqal0c2drjmvh93vnyqap40rvp8axwi0a6n")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments (list #:link-scripts #~(list "ps2eps.pl")))
+ (arguments
+ (list #:link-scripts #~(list "ps2eps.pl")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'configure-ghostscript-executable
+ ;; ps2eps.pl uses the "gswin32c" ghostscript executable on
+ ;; Windows, and the "gs" ghostscript executable on Unix. It
+ ;; detects Unix by checking for the existence of the
+ ;; "/usr/bin" directory. Since Guix System does not have
+ ;; "/usr/bin", it is also detected as Windows.
+ (lambda _
+ (substitute* "scripts/ps2eps/ps2eps.pl"
+ (("gswin32c") "gs")))))))
(inputs (list perl))
(home-page "https://ctan.org/pkg/ps2eps")
(synopsis "Produce Encapsulated PostScript from PostScript")