summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-16 10:23:10 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-16 10:24:06 +0200
commitfc4b13ee822dd7a493cac82052c14590d7351536 (patch)
treeef857ae0c9ae8a2406489af412ad2dacde679151
parent591a3f5714231b0820d5814299d90dc92af6e585 (diff)
gnu: gnome-desktop: Fix tests.
* gnu/packages/gnome.scm (gnome-desktop)[arguments]: Set XDG_CACHE_HOME and XDG_CONFIG_HOME variables for the tests.
-rw-r--r--gnu/packages/gnome.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f49a33685..4750f6421a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2181,6 +2181,8 @@ offline sources, providing a centralized place for managing your contacts.")
;; Tests require a running X server and locales.
(system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
+ (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
+ (setenv "XDG_CONFIG_HOME" "/tmp")
(setenv "GUIX_LOCPATH"
(search-input-directory inputs
"lib/locale")))))))