summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-09-05 17:07:06 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:52:19 -0400
commitfe0c0be190b97b7b22e77b2c88589971f3c895e9 (patch)
tree6ec9b2d79268aa55a128c5e280cf356e7e23322b
parentfd09e7b053c7e5dd24e5fb1b3cb9b2cc95a8bf7c (diff)
gnu: skia: Update to 110.0.0f3fb7a.
* gnu/packages/graphics.scm (skia): Update to 110.0.0f3fb7a. [arguments](build-phases): Disable newly introduced libraries wuffs (general performance) and perfetto (running performance tests). Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 346871328c..2182cdeaf2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1999,9 +1999,9 @@ and engineering community.")
;; https://skia.org/docs/user/release/release_notes/. The commit used
;; should be the last commit, as recommended at
;; https://skia.org/docs/user/release/.
- (let ((version "98")
+ (let ((version "110")
(revision "0")
- (commit "55c56abac381e1ae3f0116c410bed81b05e0a38a"))
+ (commit "0f3fb7a005fb357962e8b948ff4ec6b37f11e01b"))
(package
(name "skia")
(version (git-version version revision commit))
@@ -2013,7 +2013,7 @@ and engineering community.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ldns2j1g2wj2phlxr9zqkdgs5g64pisxhwxcrq9ijn8a3jhafr2"))))
+ "1aqdnx3817hzhy60mc72j6iwaywvd3b5fj3ffpjxnnras38x2jvp"))))
(build-system gnu-build-system) ;actually GN + Ninja
(arguments
(list
@@ -2044,7 +2044,10 @@ and engineering community.")
"extra_ldflags=[\"-Wl,-rpath=" #$output "/lib\"] "
;; Disabled, otherwise the build system attempts to
;; download the SDK at build time.
- "skia_use_dng_sdk=false "))))
+ "skia_use_dng_sdk=false "
+ ;; Wuffs is a google language that may improve performance
+ ;; disabled while unpackaged
+ "skia_use_wuffs=false "))))
(replace 'build
(lambda* (#:key parallel-build? #:allow-other-keys)
(let ((job-count (if parallel-build?
@@ -2123,6 +2126,8 @@ Cflags: -I${includedir}~%" #$output #$version)))))
"--args="
"cc=\"gcc\" " ;defaults to 'cc'
"skia_compile_sksl_tests=false " ; disable some tests
+ "skia_use_perfetto=false " ; disable performance tests
+ "skia_use_wuffs=false " ; missing performance tool
"skia_use_system_expat=true " ; use system expat library
;; Specify where to locate the includes.
"extra_cflags=["