summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 19:06:45 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 20:03:24 +0200
commit0de7945dc47612286ef080315a5a78f019b161b6 (patch)
tree6fd429da1ed8246cd1b9b034c8e0522813596c05
parent9df9a878c0a8f0c4503432bb38b16a74d1fa523d (diff)
gnu: python-pyflakes: Remove obsolete patch.
This patch was added on 'core-updates' in 43c889de85e79f279931d6cced261f54c9be5075, but no longer necessary since the update to 2.3.1 in 91741db5397174a2e96b4010c3c9ff53d34e8ef0. * gnu/packages/patches/python-pyflakes-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-xyz.scm (python-pyflakes)[source](patches): Remove.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pyflakes-fix-tests.patch40
-rw-r--r--gnu/packages/python-xyz.scm3
3 files changed, 1 insertions, 43 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ad889557c8..ecbf67118e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1567,7 +1567,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-keras-integration-test.patch \
%D%/packages/patches/python-pep8-stdlib-tokenize-compat.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
- %D%/packages/patches/python-pyflakes-fix-tests.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-libxml2-python39-compat.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
diff --git a/gnu/packages/patches/python-pyflakes-fix-tests.patch b/gnu/packages/patches/python-pyflakes-fix-tests.patch
deleted file mode 100644
index 48107c8253..0000000000
--- a/gnu/packages/patches/python-pyflakes-fix-tests.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From c873a25136dfdb062855b595cdf0a992ac825adf Mon Sep 17 00:00:00 2001
-From: Louis Sautier <sautier.louis@gmail.com>
-Date: Sat, 3 Oct 2020 01:36:15 +0200
-Subject: [PATCH] Fix tests with Python 3.9, closes #549
-
----
- pyflakes/test/test_api.py | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/pyflakes/test/test_api.py b/pyflakes/test/test_api.py
-index 8e1e3c9c..906fb396 100644
---- a/pyflakes/test/test_api.py
-+++ b/pyflakes/test/test_api.py
-@@ -517,6 +515,8 @@ def foo(bar=baz, bax):
- if ERROR_HAS_LAST_LINE:
- if PYPY:
- column = 7
-+ elif sys.version_info >= (3, 9):
-+ column = 21
- elif sys.version_info >= (3, 8):
- column = 9
- else:
-@@ -545,6 +545,8 @@ def test_nonKeywordAfterKeywordSyntaxError(self):
- if ERROR_HAS_LAST_LINE:
- if PYPY:
- column = 12
-+ elif sys.version_info >= (3, 9):
-+ column = 17
- elif sys.version_info >= (3, 8):
- column = 14
- else:
-@@ -579,6 +581,8 @@ def test_invalidEscape(self):
- position_end = 1
- if PYPY:
- column = 6
-+ elif ver >= (3,9):
-+ column = 13
- else:
- column = 7
- # Column has been "fixed" since 3.2.4 and 3.3.1
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 85b3b5ad0b..29f2d056f1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9076,8 +9076,7 @@ PEP 8.")
(uri (pypi-uri "pyflakes" version))
(sha256
(base32
- "1ny10364ciqh4ripasj4zzv4145l21l3s85m3qlrvfq5pk58xg7m"))
- (patches (search-patches "python-pyflakes-fix-tests.patch"))))
+ "1ny10364ciqh4ripasj4zzv4145l21l3s85m3qlrvfq5pk58xg7m"))))
(build-system python-build-system)
(home-page "https://github.com/PyCQA/pyflakes")
(synopsis "Passive checker of Python programs")