summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-05-20 22:55:55 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-21 11:10:30 +0200
commit20eb41b66adc5933cf34323a3c010b8d57ab7eae (patch)
treee1c33ca02317a59bc15083d1448e0ab2d4d4b429
parent2a60770f47ca9dbb5206844348d57df24140784f (diff)
gnu: Add cl-json-streams.
* gnu/packages/lisp-xyz.scm (sbcl-json-streams, ecl-json-streams, cl-json-streams): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1d48afb23b..7db71f4774 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16812,3 +16812,35 @@ is built on top of the @code{libev} event library.")
(define-public ecl-woo
(sbcl-package->ecl-package sbcl-woo))
+
+(define-public sbcl-json-streams
+ (let ((commit "5da012e8133affbf75024e7500feb37394690752")
+ (revision "1"))
+ (package
+ (name "sbcl-json-streams")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rotatef/json-streams")
+ (commit commit)))
+ (file-name (git-file-name "json-streams" version))
+ (sha256
+ (base32 "0cia3721im04q73dfkd688d8splgpz03qa4h8s3r39kar4w3xll2"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("cl-quickcheck" ,sbcl-cl-quickcheck)
+ ("flexi-streams" ,sbcl-flexi-streams)))
+ (home-page "https://github.com/rotatef/json-streams")
+ (synopsis "Common Lisp library for reading and writing JSON")
+ (description
+ "This package provides a stream based JSON parser/writer, well suited as
+building block for higher level libraries.")
+ (license license:gpl3+))))
+
+(define-public cl-json-streams
+ (sbcl-package->cl-source-package sbcl-json-streams))
+
+(define-public ecl-json-streams
+ (sbcl-package->ecl-package sbcl-json-streams))