summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 13:21:03 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commit4250b256d76f774819a77d45b98344a08794a2a4 (patch)
tree66b2e0b829cf1262ef7ca277654c8273b2913109
parent42db0f4e3356d71f4c223402f461e0ed8798c2cd (diff)
gnu: doxygen: Update to 1.9.1.
* gnu/packages/patches/doxygen-1.8.17-runtests.patch, gnu/packages/patches/doxygen-test.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/documentation.scm (doxygen): Update to 1.9.1. [source](patches): Remove. [home-page]: Use HTTPS. [arguments]: Disable bibtex test with a phase instead of patch.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/documentation.scm14
-rw-r--r--gnu/packages/patches/doxygen-1.8.17-runtests.patch73
-rw-r--r--gnu/packages/patches/doxygen-test.patch60
4 files changed, 9 insertions, 140 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2627bb62ab..d62dd6ae62 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -953,8 +953,6 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/docker-fix-tests.patch \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
- %D%/packages/patches/doxygen-test.patch \
- %D%/packages/patches/doxygen-1.8.17-runtests.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
%D%/packages/patches/dstat-skip-devices-without-io.patch \
%D%/packages/patches/dune-istl-2.7-fix-non-mpi-tests.patch \
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index ae8553436e..708d80fe48 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -203,8 +203,8 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
- (version "1.8.17")
- (home-page "http://www.doxygen.nl/")
+ (version "1.9.1")
+ (home-page "https://www.doxygen.nl/")
(source (origin
(method url-fetch)
(uri (list (string-append home-page "files/doxygen-"
@@ -214,9 +214,7 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
- "16dmv0gm1x8rvbm82fmjvi213q8fxqxinm75pcf595flya59ific"))
- (patches (search-patches "doxygen-test.patch"
- "doxygen-1.8.17-runtests.patch"))))
+ "1lcif1qi20gf04qyjrx7x367669g17vz2ilgi4cmamp1whdsxbk7"))))
(build-system cmake-build-system)
(native-inputs
`(("bison" ,bison)
@@ -236,6 +234,12 @@ markup) can be customized and extended by the user.")
'())
#:test-target "tests"
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-bibtex-test
+ (lambda _
+ ;; Disable test that requires bibtex to avoid a
+ ;; circular dependency.
+ (for-each delete-file-recursively
+ '("testing/012" "testing/012_cite.dox"))))
(add-before 'configure 'patch-sh
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/portable.cpp"
diff --git a/gnu/packages/patches/doxygen-1.8.17-runtests.patch b/gnu/packages/patches/doxygen-1.8.17-runtests.patch
deleted file mode 100644
index 0340c72448..0000000000
--- a/gnu/packages/patches/doxygen-1.8.17-runtests.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-1.8.17 was released with a broken test runner.
-
-https://github.com/doxygen/doxygen/issues/7464
-
-Taken from upstream:
-https://github.com/doxygen/doxygen/commit/cd9dee013dc749a10bbe019c350e0e62b6635795
-
-diff --git a/testing/runtests.py b/testing/runtests.py
-index a4118b865..10fe50214 100755
---- a/testing/runtests.py
-+++ b/testing/runtests.py
-@@ -3,6 +3,7 @@
- from __future__ import print_function
- import argparse, glob, itertools, re, shutil, os, sys
- import subprocess
-+import shlex
-
- config_reg = re.compile('.*\/\/\s*(?P<name>\S+):\s*(?P<value>.*)$')
-
-@@ -28,10 +29,10 @@ def xpopen(cmd, cmd1="",encoding='utf-8-sig', getStderr=False):
- return os.popen(cmd).read() # Python 2 without encoding
- else:
- if (getStderr):
-- proc = subprocess.run(cmd1,encoding=encoding,capture_output=True) # Python 3 with encoding
-- return proc.stderr
-+ proc = subprocess.Popen(shlex.split(cmd1),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
-+ return proc.stderr.read()
- else:
-- proc = subprocess.Popen(cmd,stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
-+ proc = subprocess.Popen(shlex.split(cmd),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
- return proc.stdout.read()
-
- class Tester:
-@@ -137,7 +138,7 @@ def prepare_test(self):
- print('GENERATE_DOCBOOK=NO', file=f)
- if (self.args.xhtml):
- print('GENERATE_HTML=YES', file=f)
-- # HTML_OUTPUT can also be set locally
-+ # HTML_OUTPUT can also have been set locally
- print('HTML_OUTPUT=%s/html' % self.test_out, file=f)
- print('HTML_FILE_EXTENSION=.xhtml', file=f)
- if (self.args.pdf):
-@@ -184,7 +185,7 @@ def update_test(self,testmgr):
- print('Non-existing file %s after \'check:\' statement' % check_file)
- return
- # convert output to canonical form
-- data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file)).read()
-+ data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file))
- if data:
- # strip version
- data = re.sub(r'xsd" version="[0-9.-]+"','xsd" version=""',data).rstrip('\n')
-@@ -326,7 +327,7 @@ def perform_test(self,testmgr):
- tests.append(glob.glob('%s/*.xml' % (docbook_output)))
- tests.append(glob.glob('%s/*/*/*.xml' % (docbook_output)))
- tests = ' '.join(list(itertools.chain.from_iterable(tests))).replace(self.args.outputdir +'/','').replace('\\','/')
-- exe_string = '%s --nonet --postvalid %s' % (self.args.xmllint,tests)
-+ exe_string = '%s --noout --nonet --postvalid %s' % (self.args.xmllint,tests)
- exe_string1 = exe_string
- exe_string += ' %s' % (redirx)
- exe_string += ' %s more "%s/temp"' % (separ,docbook_output)
-@@ -346,7 +347,11 @@ def perform_test(self,testmgr):
- redirx=' 2> %s/temp >nul:'%html_output
- else:
- redirx='2>%s/temp >/dev/null'%html_output
-- exe_string = '%s --path dtd --nonet --postvalid %s/*xhtml' % (self.args.xmllint,html_output)
-+ check_file = []
-+ check_file.append(glob.glob('%s/*.xhtml' % (html_output)))
-+ check_file.append(glob.glob('%s/*/*/*.xhtml' % (html_output)))
-+ check_file = ' '.join(list(itertools.chain.from_iterable(check_file))).replace(self.args.outputdir +'/','').replace('\\','/')
-+ exe_string = '%s --noout --path dtd --nonet --postvalid %s' % (self.args.xmllint,check_file)
- exe_string1 = exe_string
- exe_string += ' %s' % (redirx)
- exe_string += ' %s more "%s/temp"' % (separ,html_output)
diff --git a/gnu/packages/patches/doxygen-test.patch b/gnu/packages/patches/doxygen-test.patch
deleted file mode 100644
index 1c0d4eb946..0000000000
--- a/gnu/packages/patches/doxygen-test.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Modify the expected outcome of test 012 so that it passes when bibtex is
-not in the path, as we do not wish to add texlive as an input just for this
-test.
-
-diff -u -r doxygen-1.8.7.orig/testing/012/citelist.xml doxygen-1.8.7/testing/012/citelist.xml
---- doxygen-1.8.7.orig/testing/012/citelist.xml 2014-04-24 23:43:34.000000000 +0200
-+++ doxygen-1.8.7/testing/012/citelist.xml 2014-04-24 23:49:43.000000000 +0200
-@@ -6,38 +6,6 @@
- <briefdescription>
- </briefdescription>
- <detaileddescription>
-- <para>
-- <variablelist>
-- <varlistentry>
-- <term><anchor id="citelist_1CITEREF_Be09"/>[1]</term>
-- </varlistentry>
-- <listitem>
-- <para>P.<nonbreakablespace/>Belotti. <ulink url="http://doi.org/10.1007/978-1-4614-1927-3_5">Disjunctive cuts for non-convex MINLP</ulink>. In <ulink url="#CITEREF_LeLe12">Lee and Leyffer</ulink> <ulink url="#CITEREF_LeLe12">[4]</ulink>, pages 117<ndash/>144.</para>
-- <para/>
-- </listitem>
-- <varlistentry>
-- <term><anchor id="citelist_1CITEREF_BertholdHeinzVigerske2009"/>[2]</term>
-- </varlistentry>
-- <listitem>
-- <para>T.<nonbreakablespace/>Berthold, S.<nonbreakablespace/>Heinz, and S.<nonbreakablespace/>Vigerske. <ulink url="http://doi.org/10.1007/978-1-4614-1927-3_15">Extending a CIP framework to solve MIQCPs</ulink>. In <ulink url="#CITEREF_LeLe12">Lee and Leyffer</ulink> <ulink url="#CITEREF_LeLe12">[4]</ulink>, pages 427<ndash/>444.</para>
-- <para/>
-- </listitem>
-- <varlistentry>
-- <term><anchor id="citelist_1CITEREF_knuth79"/>[3]</term>
-- </varlistentry>
-- <listitem>
-- <para>Donald<nonbreakablespace/>E. Knuth. <emphasis>Tex and Metafont, New Directions in Typesetting</emphasis>. American Mathematical Society and Digital Press, Stanford, 1979.</para>
-- <para/>
-- </listitem>
-- <varlistentry>
-- <term><anchor id="citelist_1CITEREF_LeLe12"/>[4]</term>
-- </varlistentry>
-- <listitem>
-- <para>Jon Lee and Sven Leyffer, editors. <ulink url="http://doi.org/10.1007/978-1-4614-1927-3"><emphasis>Mixed Integer Nonlinear Programming</emphasis></ulink>, volume 154 of <emphasis>The IMA Volumes in Mathematics and its Applications</emphasis>. Springer, 2012.</para>
-- <para/>
-- </listitem>
-- </variablelist>
-- </para>
- </detaileddescription>
- </compounddef>
- </doxygen>
-diff -u -r doxygen-1.8.7.orig/testing/012/indexpage.xml doxygen-1.8.7/testing/012/indexpage.xml
---- doxygen-1.8.7.orig/testing/012/indexpage.xml 2014-04-24 23:43:34.000000000 +0200
-+++ doxygen-1.8.7/testing/012/indexpage.xml 2014-04-24 23:44:05.000000000 +0200
-@@ -6,8 +6,8 @@
- <briefdescription>
- </briefdescription>
- <detaileddescription>
-- <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[3]</ref> for more info.</para>
-- <para>Other references with cross references see <ref refid="citelist_1CITEREF_Be09" kindref="member">[1]</ref> and <ref refid="citelist_1CITEREF_BertholdHeinzVigerske2009" kindref="member">[2]</ref> for more info. </para>
-+ <para>See knuth79 for more info.</para>
-+ <para>Other references with cross references see Be09 and BertholdHeinzVigerske2009 for more info. </para>
- </detaileddescription>
- </compounddef>
- </doxygen>