summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 12:15:43 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commit42db0f4e3356d71f4c223402f461e0ed8798c2cd (patch)
tree22fdf79826d1807325c196a58829d05bb3e253f1
parent6daa0b5af3282bd3433605825bbe7f5d20dd6f4c (diff)
gnu: SWIG: Update to 4.0.2.
* gnu/packages/swig.scm (swig): Update to 4.0.2. [arguments]: Remove.
-rw-r--r--gnu/packages/swig.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 86c1407da9..b14bcd6401 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;;
@@ -35,7 +35,7 @@
(define-public swig
(package
(name "swig")
- (version "4.0.1")
+ (version "4.0.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
@@ -43,18 +43,8 @@
name "-" version ".tar.gz"))
(sha256
(base32
- "1ac7g0gd8ndwv3ybqn5vjgqxa7090bby4db164a7mn9ssp8b803s"))))
+ "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'workaround-gcc-bug
- (lambda _
- ;; XXX: Don't add the -isystem flag, or GCCs #include_next
- ;; won't be able to find <stdlib.h>.
- (substitute* "configure"
- (("-isystem ") "-I"))
- #t)))))
(native-inputs `(("boost" ,boost)
("pcre" ,pcre "bin") ;for 'pcre-config'
;; The following are for tests and examples: