summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-22 07:13:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-22 07:14:28 +0200
commit9860c4fdce5e73f24a584d7245d44b2b9129096b (patch)
tree1cfc9d505fa25eda2c62aa37606e39069fdfeec6
parenta1a7a33b17706b51c455fb1a193226bf51e3a705 (diff)
gnu: Add emacs-poly-noweb.
* gnu/packages/emacs-xyz.scm (emacs-poly-noweb): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7656c32b2e..cc843bfb78 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14851,6 +14851,29 @@ literate programming tools for exporting, weaving and tangling.")
files using the major mode corresponding to each block.")
(license license:gpl3+)))
+(define-public emacs-poly-noweb
+ (package
+ (name "emacs-poly-noweb")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/polymode/poly-noweb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jl5h4nf10xd2gdlsxi6h2n3z5zh26ffcixn68xfp5q4zl34zk8p"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-polymode" ,emacs-polymode)))
+ (home-page "https://github.com/polymode/poly-noweb")
+ (synopsis "Polymode for noweb")
+ (description
+ "This package provides @code{poly-noweb-mode}, a polymode for noweb
+files.")
+ (license license:gpl3+)))
+
(define-public emacs-powershell
;; Tagged branch 0.1 is outdated (2015).
(let ((revision "0")