summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 18:37:32 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 20:03:24 +0200
commit9df9a878c0a8f0c4503432bb38b16a74d1fa523d (patch)
treef6a92c94deaffc1665a9a8695ca578cc1145fd52
parent3ef5ee3ffbafe1b1cde1a3df0e4f8838a0314164 (diff)
gnu: python-tqdm: Update to 4.60.0.
* gnu/packages/python-xyz.scm (python-tqdm): Update to 4.60.0. [native-inputs]: Remove PYTHON-NOSE. Add PYTHON-PYTEST, PYTHON-PYTEST-ASYNCIO, PYTHON-PYTEST-TIMEOUT, PYTHON-SETUPTOOLS-SCM, and PYTHON-TOML. [arguments]: Use pytest instead of nosetests in check phase.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07bc418ec6..85b3b5ad0b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18605,25 +18605,26 @@ ignoring formatting changes.")
(define-public python-tqdm
(package
(name "python-tqdm")
- (version "4.43.0")
+ (version "4.60.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tqdm" version))
(sha256
(base32
- "093v4c2x5hpigv47zvyxl8wh10y2yd2gvz3l9vchn0zsp8hv2pzk"))))
+ "1bjpy4mjg6ryp0ijvqi77vgs76l5hh3zrv3x4vmcwxrlbswvvppb"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- ;; This invokation is taken from tox.ini.
- (invoke "nosetests" "--ignore-files=\"test_perf.py\""
- "-d" "-v" "tqdm/"))))))
+ (lambda _
+ (invoke "pytest" "-vv" "-k" "not perf"))))))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)
+ ("python-pytest-timeout" ,python-pytest-timeout)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-toml" ,python-toml)))
(home-page "https://github.com/tqdm/tqdm")
(synopsis "Fast, extensible progress meter")
(description