summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 11:32:39 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commitb08d989045450c72260e3781ef458555b9e2597c (patch)
tree059a69b93aa2cd6d5209b7e8bfe8bf4995ada8d9
parent52f4ba9617d39f52d5a1db3aadfe6475221e3d43 (diff)
gnu: boost: Update to 1.76.0.
* gnu/packages/patches/boost-fix-transitive-linking.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/boost.scm (boost): Update to 1.76.0. [source](patches): Remove.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/boost.scm6
-rw-r--r--gnu/packages/patches/boost-fix-transitive-linking.patch16
3 files changed, 2 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7fc15993d7..e08f581787 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -879,7 +879,6 @@ dist_patch_DATA = \
%D%/packages/patches/blender-2.79-oiio2.patch \
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
%D%/packages/patches/blender-2.79-python-3.8-fix.patch \
- %D%/packages/patches/boost-fix-transitive-linking.patch \
%D%/packages/patches/bpftrace-disable-bfd-disasm.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/cairo-CVE-2018-19876.patch \
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index c6cf452f09..e9da56e115 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -66,17 +66,15 @@
(define-public boost
(package
(name "boost")
- (version "1.75.0")
+ (version "1.76.0")
(source (origin
(method url-fetch)
(uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
version "/source/boost_"
(version-with-underscores version) ".tar.bz2"))
- ; Should be included in next Boost update
- (patches (search-patches "boost-fix-transitive-linking.patch"))
(sha256
(base32
- "1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
+ "0hcc661savk32hx65997p0ss1awj6ala4cmz4w7lbi42x6k7nfgh"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))
diff --git a/gnu/packages/patches/boost-fix-transitive-linking.patch b/gnu/packages/patches/boost-fix-transitive-linking.patch
deleted file mode 100644
index a42feab109..0000000000
--- a/gnu/packages/patches/boost-fix-transitive-linking.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Patch from https://github.com/boostorg/boost_install/issues/47
-which should be included in the Boost 1.76 release.
-
-This patch prevents CMake from explicitly linking against Boost dependencies
-when building against the shared Boost libraries.
---- a/tools/boost_install/boost-install.jam
-+++ b/tools/boost_install/boost-install.jam
-@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * : properties * )
-
- .info " deps3=" $(deps3) ;
-
-- if $(deps3)
-+ if $(deps3) && $(link) = static
- {
- print.text
-