summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-18 12:51:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-23 22:23:27 +0300
commitdc25a9dfa8cfac29a3f60596d36877e5d5b45679 (patch)
tree356f2d4d8d7b8b0dd2ee498f62aae5828bce2c1a
parentcbdb7d4fea928febc105985c03b8fb5d6eda3d27 (diff)
gnu: gcc-boot0: Use 128-bit long-double on powerpc-linux.
* gnu/packages/commencement.scm (gcc-boot0)[arguments]: Adjust configure-flag to also use '--with-long-double-128' on powerpc-linux.
-rw-r--r--gnu/packages/commencement.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8da13ee866..f08227b1be 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2732,12 +2732,12 @@ exec " gcc "/bin/" program
"--disable-shared"
"--enable-languages=c,c++"
- ;; boot-triplet inserts "guix" in the triplet.
- ,@(if (equal? "powerpc64le-guix-linux-gnu" (boot-triplet))
- ;; On POWER9 (little endian) glibc needs the
- ;; 128-bit long double type.
- '("--with-long-double-128")
- '())
+ ;; On POWER9 (little endian) glibc needs the 128-bit
+ ;; long double type. 32-bit PPC is affected by the
+ ;; changes applied for powerpc64le.
+ ,@(if (string-prefix? "powerpc" (boot-triplet))
+ '("--with-long-double-128")
+ '())
;; libstdc++ cannot be built at this stage
;; ("Link tests are not allowed after