summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-19 18:55:57 +0300
committerChris Marusich <cmmarusich@gmail.com>2021-03-10 23:01:59 -0800
commit3d43a7c048122eec099f48d0a122112ec34ca295 (patch)
tree8b889aefd39ae1ecf5828253432c610e57244fdb
parent4bd672cb41f71a309566dde9397dab90a4389ab7 (diff)
gnu: binutils-final: Provide bash for binary on powerpc-linux.
* gnu/packages/commencement.scm (binutils-final)[arguments]: On powerpc-linux allow a reference to static-bash-for-glibc. [inputs]: On powerpc-linux add static-bash-for-glibc.
-rw-r--r--gnu/packages/commencement.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 6fc224f9c8..c42185728c 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3402,9 +3402,19 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
- #:allowed-references ("out" ,glibc-final)
+ #:allowed-references
+ ,@(match (%current-system)
+ ("powerpc-linux"
+ `(("out" ,glibc-final ,static-bash-for-glibc)))
+ (_
+ `(("out" ,glibc-final))))
,@(package-arguments binutils)))
- (inputs (%boot2-inputs))))
+ (inputs
+ (match (%current-system)
+ ("powerpc-linux"
+ `(("bash" ,static-bash-for-glibc)
+ ,@(%boot2-inputs)))
+ (_ (%boot2-inputs))))))
(define libstdc++
;; Intermediate libstdc++ that will allow us to build the final GCC