summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Le Bouter <lle-bout@zaclys.net>2021-02-09 06:10:02 +0100
committerChris Marusich <cmmarusich@gmail.com>2021-03-10 23:02:01 -0800
commitb13ba3eed4bbfecd6c03819768cafebef35f23c7 (patch)
treec56168fd61d1eee9521e81c1071b8e07275f7d74
parent3403218bfb1fefc3a4c31a65601a924996580fe6 (diff)
gnu: libelf: Fix compilation for powerpc64le-linux.
* gnu/packages/elf.scm (libelf)[arguments]: Modify replacement 'configure phase to invoke "./configure" with "--host=powerpc64le-unknown-linux-gnu" on powerpc64le-linux. Signed-off-by: Chris Marusich <cmmarusich@gmail.com>
-rw-r--r--gnu/packages/elf.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 2e21cab48d..aab912648b 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Mark Wielaard <mark@klomp.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -211,6 +212,10 @@ static analysis of the ELF binaries at hand.")
(setenv "CONFIG_SHELL" (which "bash"))
(invoke "./configure"
(string-append "--prefix=" out)
+ ,@(if (string=? "powerpc64le-linux"
+ (%current-system))
+ '("--host=powerpc64le-unknown-linux-gnu")
+ '())
,@(if (string=? "aarch64-linux"
(%current-system))
'("--host=aarch64-unknown-linux-gnu")