summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-05 13:33:10 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-05 17:26:19 +0100
commitbe2b2e884b1061c0509e962e80bb477e31bd2acb (patch)
tree7af4a2ae9c039fb4d71399ff575f6ed5da9c79aa
parente693927a747e36a8c7bef042f7be92f15304cc8b (diff)
gnu: Add emacs-envrc.
* gnu/packages/emacs-xyz.scm (emacs-envrc): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c312b7c9fb..cfd1fdeb86 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -93,6 +93,7 @@
;;; Copyright © 2021 Alexandr Vityazev <avityazew@gmail.com>
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13667,6 +13668,32 @@ query them from the comfort of your editor.")
(home-page "https://github.com/hrs/engine-mode")
(license license:gpl3+)))
+(define-public emacs-envrc
+ (package
+ (name "emacs-envrc")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/envrc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ssf9i6iym2rb530k2w5aj392qa73i6p5y0vwrs5qhkv9lagqq7p"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/envrc")
+ (synopsis "Support for Direnv which operates buffer-locally")
+ (description
+ "This is library which uses Direnv to set environment variables on
+a per-buffer basis. This means that when you work across multiple projects
+which have @file{.envrc} files, all processes launched from the buffers ``in''
+those projects will be executed with the environment variables specified in
+those files. This allows different versions of linters and other tools to be
+used in each project if desired.")
+ (license license:gpl3+)))
+
(define-public emacs-prop-menu
(package
(name "emacs-prop-menu")