summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-02-10 20:45:25 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:04 +0100
commit024f9d9f43b1a1f283f67dbfe88dc13ad7a41332 (patch)
tree44dd999cdf856dfbc749b46cff6fec6612aa133a
parentca6d2cf25233ec09a7190455778758ad254a34b5 (diff)
gnu: Add python-pytest-memprof.
* gnu/packages/python-check.scm (python-pytest-memprof): New variable.
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 547813cce7..8b534c6245 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2029,3 +2029,23 @@ eliminate flaky failures.")
Python objects. It tries to use the objects available in the standard
@code{unittest} module.")
(license license:expat)))
+
+(define-public python-pytest-memprof
+ (package
+ (name "python-pytest-memprof")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-memprof" version))
+ (sha256
+ (base32 "0rxg0q3bwlc9iax0skpia3a5x7xijz9i5110qk50vf9avwg9zg69"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ;; No tests, no git repository
+ (propagated-inputs (list python-psutil python-pytest))
+ ;; The gitlab repository is private, so the home page is not accessible.
+ (home-page "https://pypi.org/project/pytest-memprof/")
+ (synopsis "Estimate memory consumption of test functions")
+ (description "This pytest plugin estimates memory consumption of test
+functions.")
+ (license license:bsd-3)))