summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 15:39:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
commit0652026c6bc7edae47738a6beaacea8740182a09 (patch)
treec8a37df13fccaef7edc760b9e139713f62e1c331
parent1cdd6b09c8bc45c1ae5a16f16d5bcf33ab0ceb5e (diff)
gnu: Add python-imageio-ffmpeg.
* gnu/packages/python-xyz.scm (python-imageio-ffmpeg): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c003e3c1a..57181f7a7d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25466,6 +25466,38 @@ usable as a configuration language. This Python package implements parsing and
dumping of JSON5 data structures.")
(license license:asl2.0)))
+(define-public python-imageio-ffmpeg
+ (package
+ (name "python-imageio-ffmpeg")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imageio-ffmpeg" version))
+ (sha256
+ (base32 "0ff14079izsyxwf6ki68k9a7w5krjlal7lwqvzg2bbddl92l5spj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ;; Most tests download data (use the git url)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-ffmpeg-exe
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; There are different strategies to find ffmpeg, we
+ ;; only fix the last resort, "system ffmpeg command"
+ (substitute* "imageio_ffmpeg/_utils.py"
+ (("exe = \"ffmpeg\"")
+ (format #f "exe = ~s"
+ (search-input-file
+ inputs "/bin/ffmpeg")))))))))
+ (inputs (list ffmpeg))
+ (home-page "https://github.com/imageio/imageio-ffmpeg")
+ (synopsis "@samp{ffmpeg} wrapper for Python")
+ (description
+ "The purpose of this project is to wrap the @command{ffmpeg} executable
+for working with video files.")
+ (license license:bsd-2)))
+
(define-public python-frozendict
(package
(name "python-frozendict")