summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:35:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:02 +0100
commit110fe7cd616e58adbd5f03365f89d28be62f3836 (patch)
tree0ffae4005b0922b06d2e97cd6c5942106f09156c
parente9fcf198c3f648774d18dcd4ccd72bb37a26bd94 (diff)
gnu: Add python-pytest-cases.
* gnu/packages/python-xyz.scm (python-pytest-cases): New variable.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b9802fdd4d..e63925b2ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25679,6 +25679,14 @@ function.")
python-pytest-cases-minimal python-setuptools-scm
python-pytest-logging))))
+(define-public python-pytest-cases
+ (package
+ (inherit python-pytest-cases-minimal)
+ (name "python-pytest-cases")
+ (arguments '())
+ ;; Propagate the tested decopatch instead of decopatch-minimal
+ (propagated-inputs (list python-decopatch python-makefun))))
+
(define-public python-frozendict
(package
(name "python-frozendict")