summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-02-06 23:47:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:03 +0100
commit13b5e767b029175d25dc994f3c9c40503711598d (patch)
treead7c2344e743edaecc14507b2e3bfb6b5f1c8ed7
parentdb8f55cef687983e681ffd186572c55a52c17ef0 (diff)
gnu: Add python-nilearn.
* gnu/packages/python-science.scm (python-nilearn): New variable.
-rw-r--r--gnu/packages/python-science.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 6a6924eac6..3ada23bb57 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1156,6 +1156,42 @@ limited support for @url{http://medical.nema.org/, DICOM}. NiBabel is the
successor of @url{http://niftilib.sourceforge.net/pynifti/, PyNIfTI}.")
(license license:expat)))
+(define-public python-nilearn
+ (package
+ (name "python-nilearn")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nilearn" version))
+ (sha256
+ (base32 "0xpy479kvcnrv9rkirisgm17iqcxd6sj8xzc1a8qj57mvq5f7j7r"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "--pyargs" "nilearn")))))))
+ (propagated-inputs
+ (list python-joblib
+ python-nibabel
+ python-numpy
+ python-pandas
+ python-requests
+ python-scikit-learn
+ python-scipy))
+ (native-inputs
+ (list python-pytest python-pytest-cov python-codecov python-lxml))
+ (home-page "https://nilearn.github.io")
+ (synopsis "Statistical learning for neuroimaging in Python")
+ (description "Nilearn supports general linear model (GLM) based analysis
+and leverages the scikit-learn Python toolbox for multivariate statistics with
+applications such as predictive modelling, classification, decoding, or
+connectivity analysis. It includes the functionality of nistats.")
+ (license license:bsd-3)))
+
(define-public python-nitime
(package
(name "python-nitime")