summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
commit1cdd6b09c8bc45c1ae5a16f16d5bcf33ab0ceb5e (patch)
treebab1cc2f32bdbf73ed654693f6e4887ffb2ed08e
parent2b2f8c6b59fbab06c5e3bfe057c12404160446d4 (diff)
gnu: lsh: Fix build with GCC 10.
* gnu/packages/ssh.scm (lsh)[arguments]: Add "CFLAGS=-fcommon" to #:configure-flags. Don't explicitly return #t from phases. [source]: Don't explicitly return #t from snippet.
-rw-r--r--gnu/packages/ssh.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 4dd8bb6d96..363ff22e29 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -594,8 +594,7 @@ basis for almost any application.")
(("localhost") "127.0.0.1"))
(substitute* "src/testsuite/login-auth-test"
- (("/bin/cat") "cat"))
- #t))
+ (("/bin/cat") "cat"))))
(patches (search-patches "lsh-fix-x11-forwarding.patch"))))
(build-system gnu-build-system)
(native-inputs
@@ -629,7 +628,10 @@ basis for almost any application.")
;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
;; defines it.
- "CPPFLAGS=-DHAVE_ARGP_PARSE")
+ "CPPFLAGS=-DHAVE_ARGP_PARSE"
+
+ ;; Fix the build of lsh@2.1 with GCC 10.
+ "CFLAGS=-fcommon")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-failing-tests
@@ -642,8 +644,7 @@ basis for almost any application.")
(("seed-test \\\\") ;prevent trailing slash
"seed-test")
(("^\t(lsh|daemon|tcpip|socks|lshg|lcp|rapid7|lshd).*test.*")
- ""))
- #t))
+ ""))))
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(let* ((nettle (assoc-ref inputs "nettle"))