summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:34:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:01 +0100
commit23444d3eed6dea5352b8580856209b18d48a6a6d (patch)
tree7a757db2c9d1184a9be05ba89122df1a82b18f76
parent723391bcb0a0a3a7ecf395b88edbb45d6616a77a (diff)
gnu: Add a test-less python-pytest-steps.
* gnu/packages/python-xyz.scm (python-pytest-steps-minimal): New variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a4e8955b4f..a8c2f47079 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25601,6 +25601,30 @@ decorators is simple and straightforward.")
at the end of the session, e.g. for applicative benchmarking purposes.")
(license license:bsd-3)))
+(define python-pytest-steps-minimal
+ (package
+ (name "python-pytest-steps-minimal")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-steps" version))
+ (sha256
+ (base32
+ "05r2ch7191saj7sw6d47bfa5vnyyj157dl8hvlcc78xx6jyxy46j"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs (list python-makefun python-wrapt python-tabulate
+ python-pandas))
+ (native-inputs (list python-pytest python-pytest-runner
+ python-setuptools-scm))
+ (home-page "https://github.com/smarie/python-pytest-steps")
+ (synopsis "Create step-wise / incremental tests in pytest")
+ (description "This package provides support for step-wise / incremental
+tests in pytest.")
+ (license license:bsd-3)))
+
(define-public python-frozendict
(package
(name "python-frozendict")