summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 19:12:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
commit4017957d71a3f41f75f858ead8f01251ffdfb8e3 (patch)
tree94d41ff6d42eab100cf1db01ab808efe7fe3b99e
parentbc17ffc9f356b51f8cfca182608d2b516ce9e207 (diff)
gnu: Add python-nitime.
* gnu/packages/python-science.scm (python-nitime): New variable.
-rw-r--r--gnu/packages/python-science.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c659b004ed..35b58cba88 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1155,3 +1155,37 @@ FreeSurfer} geometry, annotation and morphometry files. There is some very
limited support for @url{http://medical.nema.org/, DICOM}. NiBabel is the
successor of @url{http://niftilib.sourceforge.net/pynifti/, PyNIfTI}.")
(license license:expat)))
+
+(define-public python-nitime
+ (package
+ (name "python-nitime")
+ (version "0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nitime" version))
+ (sha256
+ (base32
+ "0x1q6ka8i330yhp5h0h6igfs2gp5dndiybyfkdi45a8zpfnr0zbf"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-matplotlib python-networkx python-nibabel
+ python-numpy python-scipy))
+ (native-inputs (list python-cython python-pytest))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-generated-cython
+ (lambda _
+ (delete-file "nitime/_utils.c")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "nitime")))))))
+ (home-page "http://nipy.org/nitime/")
+ (synopsis "Nitime: timeseries analysis for neuroscience data")
+ (description
+ "Nitime contains a core of numerical algorithms for time-series analysis
+both in the time and spectral domains, a set of container objects to represent
+time-series, and auxiliary objects that expose a high level interface to the
+numerical machinery.")
+ (license license:bsd-3)))