summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 17:17:11 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
commit593a0ef04347a35f1e3bdb7919fa15daa19d8f0a (patch)
tree5dc07ff6a62adfeb7cb0d11c6bbaf3f0330235d9
parentaf7bd831505cedba0fc699ecb85792d4e72bb599 (diff)
gnu: Add python-eeglabio.
* gnu/packages/python-science.scm (python-eeglabio): New variable.
-rw-r--r--gnu/packages/python-science.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c73802103d..78c84f4fe6 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1080,3 +1080,27 @@ European Data Format}. @dfn{BDF} is the
@url{https://www.teuniz.net/edfbrowser/bdfplus%20format%20description.html,
24-bit version} of EDF.")
(license license:bsd-3)))
+
+(define-public python-eeglabio
+ (package
+ (name "python-eeglabio")
+ (version "0.0.1.post6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackz314/eeglabio")
+ (commit "5416e8f2bc82da60ee729458cf325bec66d9774a")))
+ (sha256
+ (base32
+ "0zpb1xcvm4wzli2gfly7hr0486cnr8pl7f70dh58jmh4nj87z6i7"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; Tests require MNE
+ #:tests? #f))
+ (propagated-inputs (list python-numpy python-scipy))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/jackz314/eeglabio")
+ (synopsis "I/O support for EEGLAB files in Python")
+ (description "This project provides I/O support for EEGLAB files in Python.")
+ (license license:bsd-3)))