summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 19:20:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:00 +0100
commit5dc6f1a9e20f99b8a9f769f520dafcf7ea001410 (patch)
treed80568b9de12672ab33c332f65ff3c5e6b7f8fc1
parent4017957d71a3f41f75f858ead8f01251ffdfb8e3 (diff)
gnu: Add python-flake8-array-spacing.
* gnu/packages/python-science.scm (python-flake8-array-spacing): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 57181f7a7d..d05a633973 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25498,6 +25498,32 @@ dumping of JSON5 data structures.")
for working with video files.")
(license license:bsd-2)))
+(define-public python-flake8-array-spacing
+ (package
+ (name "python-flake8-array-spacing")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8_array_spacing" version))
+ (sha256
+ (base32 "0nyp2x45hg5dkdrn0j2wcd336dnx6csizpfq5fwbk774wrb0lh6d"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs (list python-pytest))
+ (build-system python-build-system)
+ (propagated-inputs (list python-flake8 python-pycodestyle))
+ (home-page "https://github.com/larsoner/flake8-array-spacing")
+ (synopsis "flake8 plugin to make exceptions for array-like variables")
+ (description "Recast some E2XX errors as A2XX with exceptions for
+array-like variables.")
+ (license license:bsd-3)))
+
(define-public python-frozendict
(package
(name "python-frozendict")