summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:34:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:01 +0100
commit5eed73afa458ebafb4ffa6a75bd8f049ccf785fb (patch)
treed0b24621d4d23bf65be79a04695150bec224474e
parent23444d3eed6dea5352b8580856209b18d48a6a6d (diff)
gnu: Add a test-less python-pytest-cases.
* gnu/packages/python-xyz.scm (python-pytest-cases-minimal): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a8c2f47079..9b7eb717d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25625,6 +25625,38 @@ at the end of the session, e.g. for applicative benchmarking purposes.")
tests in pytest.")
(license license:bsd-3)))
+(define python-pytest-cases-minimal
+ (package
+ (name "python-pytest-cases-minimal")
+ (version "3.6.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-cases" version))
+ (sha256
+ (base32
+ "1g3lp4m19fk83kl2b4akwg7wqqaqlfzp4v6qcb0hq27161xyh8yl"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-decopatch-minimal python-makefun))
+ (native-inputs (list python-pytest
+ python-pytest-runner
+ python-setuptools-scm
+ python-pytest-asyncio
+ python-pytest-harvest-minimal
+ python-pytest-steps-minimal))
+ (home-page "https://github.com/smarie/python-pytest-cases")
+ (synopsis "Separate test code from test cases in @samp{pytest}")
+ (description
+ "@samp{pytest-cases} leverages @samp{pytest} and its great
+@samp{@@pytest.mark.parametrize decorator}, so that you can @strong{separate
+your test cases from your test functions}. In addition, @samp{pytest-cases}
+provides several useful goodies to empower @samp{pytest}. In particular it
+improves the fixture mechanism to support \"fixture unions\". This is a
+@strong{major change} in the internal @samp{pytest} engine, unlocking many
+possibilities such as using fixture references as parameter values in a test
+function.")
+ (license license:bsd-3)))
+
(define-public python-frozendict
(package
(name "python-frozendict")