summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 21:23:04 +0100
commit60590a3ae8952ff0b5c77a722981aef514e3de66 (patch)
tree42d460aedb0a9698b3c60e49036e2fbf2ca1c03e
parent08722837b048e7d0b416e414f7e695a380e7784b (diff)
gnu: Add python-entrypoints.
* gnu/packages/python.scm (python-entrypoints, python2-entrypoints): New variables.
-rw-r--r--gnu/packages/python.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8987450d5b..9aa3e49f58 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6719,6 +6719,46 @@ Jupyter Notebook format and Python APIs for working with notebooks.")
(define-public python2-bleach
(package-with-python2 python-bleach))
+(define-public python-entrypoints
+ (package
+ (name "python-entrypoints")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/takluyver/entrypoints/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0azqlkh3j0za080lsf5crnhaxx3c93k9dpv5ihkhf5cppgw5sjz5"))))
+ (build-system python-build-system)
+ ;; The package does not come with a setup.py file, so we have to generate
+ ;; one ourselves.
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-setup.py
+ (lambda _
+ (call-with-output-file "setup.py"
+ (lambda (port)
+ (format port "\
+from setuptools import setup
+setup(name='entrypoints', version='~a', py_modules=['entrypoints'])
+" ,version))))))))
+ (home-page "https://github.com/takluyver/entrypoints")
+ (synopsis "Discover and load entry points from installed Python packages")
+ (description "Entry points are a way for Python packages to advertise
+objects with some common interface. The most common examples are
+@code{console_scripts} entry points, which define shell commands by
+identifying a Python function to run. The @code{entrypoints} module contains
+functions to find and load entry points.")
+ (license license:expat)))
+
+(define-public python2-entrypoints
+ (package-with-python2 python-entrypoints))
+
(define-public python-chardet
(package
(name "python-chardet")