summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:35:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:02 +0100
commit66a2a1dfdde5032d2503f112b53d31cde46abe7d (patch)
treec8f8be3cc2668d186bd28ee303496fc5591775b3
parent110fe7cd616e58adbd5f03365f89d28be62f3836 (diff)
gnu: Add python-pytest-harvest.
* gnu/packages/python-xyz.scm (python-pytest-harvest): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e63925b2ab..022dd23186 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25687,6 +25687,25 @@ function.")
;; Propagate the tested decopatch instead of decopatch-minimal
(propagated-inputs (list python-decopatch python-makefun))))
+(define-public python-pytest-harvest
+ (package
+ (inherit python-pytest-harvest-minimal)
+ (name "python-pytest-harvest")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'move-pytests-plugins
+ (lambda _
+ (rename-file "pytest_harvest/tests/conftest.py"
+ "conftest.py"))))))
+ (native-inputs (list python-pytest
+ python-pytest-runner
+ python-setuptools-scm
+ python-pytest-cases
+ python-tabulate
+ python-pandas))
+ (propagated-inputs (list python-decopatch python-makefun python-six))))
+
(define-public python-frozendict
(package
(name "python-frozendict")