summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:33:32 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:01 +0100
commit723391bcb0a0a3a7ecf395b88edbb45d6616a77a (patch)
tree79d72d90ff2ab3b583b865c32e94c5be9e6e3f68
parent4bcf5c589a23dbd51c7b27b9efedcd18da7047b7 (diff)
gnu: Add a test-less python-pytest-harvest.
* gnu/packages/python-xyz.scm (python-pytest-harvest-minimal): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c57992cbbf..a4e8955b4f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25576,6 +25576,31 @@ without help can be a pain because you have to handle the no-parenthesis usage
decorators is simple and straightforward.")
(license license:bsd-3)))
+(define python-pytest-harvest-minimal
+ (package
+ (name "python-pytest-harvest-minimal")
+ (version "1.10.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-harvest" version))
+ (sha256
+ (base32
+ "092drlh96rhikwqqyfpwqhkzfzd7z8m5gbmjgky8npm81849jbsk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs (list python-decopatch-minimal python-makefun
+ python-six))
+ (native-inputs (list python-pytest python-pytest-runner
+ python-setuptools-scm))
+ (home-page "https://github.com/smarie/python-pytest-harvest")
+ (synopsis "Store data created during your @samp{pytest} tests execution")
+ (description
+ "Store data created during your pytest tests execution, and retrieve it
+at the end of the session, e.g. for applicative benchmarking purposes.")
+ (license license:bsd-3)))
+
(define-public python-frozendict
(package
(name "python-frozendict")