summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-02-07 00:50:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:03 +0100
commit7881751d247b7f6e1d8e74f0662512da2fc93b73 (patch)
tree7ab9b887e6f5a237456a9f0e6d041c9ec5089a41
parent79cd1f1b74cea2e8908f97cf6bcec78cccd8dbe0 (diff)
gnu: Add python-pyperf.
* gnu/packages/python-xyz.scm (python-pyperf): New variable.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d3a57c5de..e9bf530d92 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25832,6 +25832,34 @@ function.")
__version__ number.")
(license license:cc0)))
+(define-public python-pyperf
+ (package
+ (name "python-pyperf")
+ (version "2.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyperf" version))
+ (sha256
+ (base32 "189qf9wdbig0fk4n3bavx8acgdbay5lllfvw48jvbfaafb7y5hja"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (delete-file "pyperf/tests/test_examples.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://github.com/psf/pyperf")
+ (synopsis "Python module to run and analyze benchmarks.")
+ (description "This package provides a python module to run and analyze benchmarks.")
+ (license license:expat)))
+
(define-public python-frozendict
(package
(name "python-frozendict")