summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 16:48:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:15 -0500
commit9b6a23e5249a117357fd6a8958bdbf6d4d23c428 (patch)
tree13499e9845d282be60863ec88447953979b06df4
parent37903729798cc9a3ea2b803cd7c4de4cc80572b5 (diff)
gnu: rest: Use libsoup-minimal.
This is needed to prevent a dependency cycle between Inkscape and GTK+. * gnu/packages/gnome.scm (rest)[propagated-inputs] {libsoup}: Use the minimal variant.
-rw-r--r--gnu/packages/gnome.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c04a8cbc6a..6e4efceb11 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4826,7 +4826,7 @@ from the GSettings schemas in gsettings-desktop-schemas.")
(propagated-inputs
;; rest-0.7.pc refers to all these.
`(("glib" ,glib)
- ("libsoup" ,libsoup)
+ ("libsoup" ,libsoup-minimal)
("libxml2" ,libxml2)))
(home-page "https://www.gtk.org/")
(synopsis "RESTful web api query library")