summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 23:00:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:02 +0100
commita35ab53fa9832846b6ad64f1f0fadd60a242e8a2 (patch)
treede35726ebe8e02832e937aea85a3e28bec2629f0
parentf0984ad2e69fe0b69ad8eacbe5aeac7ce0daed29 (diff)
gnu: python-pooch: Update to 1.6.0.
* gnu/packages/python-xyz.scm (python-pooch): Update to 1.6.0. [native-inputs]: Add python-setuptools-scm.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 29 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 374fba982b..1448edbb70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22290,18 +22290,44 @@ inferring type information using compile-time introspection.")
(define-public python-pooch
(package
(name "python-pooch")
- (version "1.3.0")
+ (version "1.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pooch" version))
(sha256
- (base32 "1618adsg9r8fsv422sv35z1i723q3a1iir5v7dv2sklh4pl4im1h"))))
+ (base32 "0i1zmd0v7n3yx167j18ldidfiih9n734pdjvn3999mhdn720xljp"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ;requires online data
+ (list
+ #:tests? #f ;requires online data
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: PEP 517 manual build copied from python-isort.
+ (replace 'build
+ (lambda _
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (invoke "python"
+ "-m"
+ "build"
+ "--wheel"
+ "--no-isolation"
+ ".")))
+ (replace 'install
+ (lambda _
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip"
+ "--no-cache-dir"
+ "--no-input"
+ "install"
+ "--no-deps"
+ "--prefix"
+ #$output
+ whl)))))))
(propagated-inputs
(list python-appdirs python-packaging python-requests))
+ (native-inputs
+ (list python-pypa-build python-setuptools-scm))
(home-page "https://github.com/fatiando/pooch")
(synopsis "Manage your Python library's sample data files")
(description