summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-02-06 23:03:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:03 +0100
commitbf9b2320ff90995c3111ff625bc0a88acebd7abd (patch)
tree854c9711696f44b752e40d2fa1d63185d9c6fa11
parent5c6e68f49a7e89a2980385e9289dda570d1ee08d (diff)
gnu: Add python-picard.
* gnu/packages/python-science.scm: New variable.
-rw-r--r--gnu/packages/python-science.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 35b58cba88..fc6870b5df 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1189,3 +1189,32 @@ both in the time and spectral domains, a set of container objects to represent
time-series, and auxiliary objects that expose a high level interface to the
numerical machinery.")
(license license:bsd-3)))
+
+(define-public python-picard
+ (package
+ (name "python-picard")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-picard" version))
+ (sha256
+ (base32 "19w5s77jfyy6h4h7iv639blfdil40ayz1whpfrdq0336qkqa2qc0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "picard")))))))
+ (propagated-inputs
+ (list python-numexpr python-numpy python-scikit-learn python-scipy
+ python-matplotlib))
+ (native-inputs
+ (list python-pytest))
+ (home-page "https://pierreablin.github.io/picard")
+ (synopsis "Preconditoned ICA for Real Data")
+ (description "This package provides Python code of the Preconditioned ICA
+for Real Data (Picard) and Picard-O algorithms.")
+ (license license:bsd-3)))