summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-02-06 22:36:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:02 +0100
commitbfdc6feb17568e0a22d79e5e69ccdf0872fb0a75 (patch)
tree4337f462bd2e7d6f4bf06dd88289effd14f2eb7d
parenta35ab53fa9832846b6ad64f1f0fadd60a242e8a2 (diff)
gnu: Add python-h5io.
* gnu/packages/python-xyz.scm (python-h5io): New variable.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1448edbb70..5d993722e4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1372,6 +1372,36 @@ concepts.")
(define-public python2-h5py
(package-with-python2 python-h5py))
+(define-public python-h5io
+ (package
+ (name "python-h5io")
+ (version "0.1.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/h5io/h5io")
+ (commit (string-append "h5io-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mxsai8i7br20cqnydagng814g2hwhaq4aprsq2d4kmvff45s3az"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "h5io")))))))
+ (propagated-inputs (list python-h5py python-numpy python-scipy))
+ (native-inputs (list python-pytest python-pytest-cov))
+ (home-page "http://h5io.github.io")
+ (synopsis "Python Objects Onto HDF5")
+ (description "h5io is a package designed to facilitate saving some
+standard Python objects into the forward-compatible HDF5 format. It is a
+higher-level package than h5py.")
+ (license license:bsd-3)))
+
(define-public python-hnswlib
(package
(name "python-hnswlib")