summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:35:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:01 +0100
commite9fcf198c3f648774d18dcd4ccd72bb37a26bd94 (patch)
treef54da1fe751f861618238d5956cb9cd602e3470b
parent5eed73afa458ebafb4ffa6a75bd8f049ccf785fb (diff)
gnu: Add python-decopatch.
* gnu/packages/python-xyz.scm (python-decopatch): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b7eb717d7..b9802fdd4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25657,6 +25657,28 @@ possibilities such as using fixture references as parameter values in a test
function.")
(license license:bsd-3)))
+(define-public python-decopatch
+ (package
+ (inherit python-decopatch-minimal)
+ (name "python-decopatch")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (delete-file "decopatch/tests/test_main2.py")
+ (delete-file
+ "decopatch/tests/test_main2_parametrizers.py")
+ (delete-file "decopatch/tests/test_introspection.py")
+ (delete-file
+ "decopatch/tests/test_introspection_base.py")
+ (substitute* "decopatch/tests/test_doc_advanced.py"
+ (("'uses_introspection', \\[True, False\\]")
+ "'uses_introspection', [False]")))))))
+ (native-inputs (list python-pytest python-pytest-runner
+ python-pytest-cases-minimal python-setuptools-scm
+ python-pytest-logging))))
+
(define-public python-frozendict
(package
(name "python-frozendict")