summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-01-20 22:36:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-02-13 01:00:02 +0100
commitf0984ad2e69fe0b69ad8eacbe5aeac7ce0daed29 (patch)
treee7d221de77eae013ae974c686ec0f9f28f987a96
parent66a2a1dfdde5032d2503f112b53d31cde46abe7d (diff)
gnu: Add python-pytest-steps.
* gnu/packages/python-xyz.scm (python-pytest-steps): New variable.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 022dd23186..374fba982b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25706,6 +25706,21 @@ function.")
python-pandas))
(propagated-inputs (list python-decopatch python-makefun python-six))))
+(define-public python-pytest-steps
+ (package
+ (inherit python-pytest-steps-minimal)
+ (name "python-pytest-steps")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'move-pytests-plugins
+ (lambda _
+ (rename-file "pytest_steps/tests/conftest.py"
+ "conftest.py"))))))
+ (native-inputs (list python-pytest python-pytest-runner
+ python-setuptools-scm python-pytest-cases
+ python-pytest-harvest))))
+
(define-public python-frozendict
(package
(name "python-frozendict")