summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman.scherer@burningswell.com>2022-12-19 15:18:43 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-12-19 19:28:09 +0100
commit1504edd84f1a0b4afda11cab99edc602d82085c1 (patch)
tree3a8f1217c179d37b1cfb639a5e9789350232afc8
parentd03b6fb0e3f0b81b35a9b35b89c213c144c59fe6 (diff)
gnu: Add eccodes.
* gnu/packages/geo.scm (eccodes): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/geo.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c0d5dcf7cd..4e872f6846 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -79,6 +79,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -152,6 +153,35 @@ point representations are not directly supported, they can also be efficiently
coded by grouping exponents and mantissa.")
(license license:bsd-2)))
+(define-public eccodes
+ (package
+ (name "eccodes")
+ (version "2.27.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://confluence.ecmwf.int/download/attachments/45757960/"
+ "eccodes-" version "-Source.tar.gz"))
+ (sha256
+ (base32 "16cw4v2d0kjq6gq04paqny0sh5jymn70w449mig7m5h3spzv7rgd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DENABLE_MEMFS=ON" "-DENABLE_PNG=ON")
+ #:validate-runpath? #f))
+ (inputs
+ (list jasper libaec libjpeg-turbo libpng netcdf openjpeg))
+ (native-inputs
+ (list gfortran perl pkg-config python))
+ (home-page "https://confluence.ecmwf.int/display/ECC")
+ (synopsis "Library for handling the GRIB, BUFR and GTS file formats")
+ (description "ecCodes is a package developed by @acronym{ECMWF, European
+Centre for Medium-Range Weather Forecasts} which provides an application
+programming interface and a set of tools for decoding and encoding messages in
+the @acronym{WMO, World Meteorological Organization} FM-92 GRIB, WMO FM-94
+BUFR and WMO GTS abbreviated header formats.")
+ (license license:asl2.0)))
+
(define-public cdo
(package
(name "cdo")