summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-19 01:29:53 +0100
committerMarius Bakke <marius@gnu.org>2022-12-19 23:08:22 +0100
commitb2fc209b2ce5b6f18f1cf9d8c599f52e608ace42 (patch)
treec6aca8bdeb62781cbcca604a44c22e70e8ba60ca
parent145aa7f04b1c61e52f61bca039350e898e20aac8 (diff)
gnu: SeaBIOS: Prettify version string.
* gnu/packages/firmware.scm (seabios)[arguments]: Display version as "1.16.1/GNU Guix" instead of "1.16.1-guix".
-rw-r--r--gnu/packages/firmware.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 7239b85cb2..8c8949a5da 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -423,7 +423,10 @@ executing in M-mode.")
(list
#:tests? #f ;no tests
#:make-flags
- #~'("EXTRAVERSION=-guix" ;upstream wants distros to set this
+ ;; If EXTRAVERSION is not set the build system will embed the current
+ ;; date in binaries. Use this opportunity to personalize as recommended
+ ;; by Build_overview.md.
+ #~'("EXTRAVERSION=/GNU Guix"
"V=1") ;build verbosely
#:modules `(,@%gnu-build-system-modules
(ice-9 threads)
@@ -432,9 +435,8 @@ executing in M-mode.")
#~(modify-phases %standard-phases
(replace 'configure
(lambda _
- ;; Create the ".version" file that is present in release tarballs.
- ;; Otherwise this will be regarded as an "unclean" build, and the
- ;; build system ends up encoding the build date in the binaries.
+ ;; Ensure this file is present in case we're building from a git
+ ;; checkout instead of release tarball.
(call-with-output-file ".version"
(lambda (port)
(format port #$(package-version this-package))))