summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-03-13 22:53:02 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:12 -0400
commit269f8dce259fc65bc2dec30f58ebb6f0db129b61 (patch)
treec56cc033883c87248f7d3edb34a8baeb2449d8af
parent865df7f080c64960f349fff79088427889e6c492 (diff)
gnu: Add ruby-unicode-plot.
* gnu/packages/plotutils.scm (ruby-unicode-plot): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/plotutils.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index fdda6d4871..34f507e825 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -456,29 +456,3 @@ characters. Supported charts are: barplot, boxplot, densityplot,
histogram, lineplot, and scatterplot.")
(home-page "https://github.com/red-data-tools/unicode_plot.rb")
(license license:expat)))
-
-(define-public youplot
- (package
- (name "youplot")
- (version "0.4.5")
- ;; Source at RubyGems.org doesn't have tests.
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/red-data-tools/YouPlot")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1y54apw7hx9mhjnf277w9wayvq954mdnip4dpajhc0qjg2464c2b"))))
- (build-system ruby-build-system)
- (native-inputs (list ruby-rake ruby-simplecov ruby-test-unit))
- (propagated-inputs (list ruby-unicode-plot))
- (synopsis "Command line tool that draw plots on the terminal")
- (description
- "YouPlot is a command line tool that draws plots on the terminal,
-powered by UnicodePlot gem. It provides commands @command{youplot}
-and @command{uplot} (shorthand) are provided, and supports chart types
-of barplot, histogram, lineplot, scatter, density, boxplot, and count.")
- (home-page "https://github.com/red-data-tools/YouPlot")
- (license license:expat)))