summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Andrews <kyle@posteo.net>2023-04-01 04:57:02 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:12 -0400
commit4e9c9a63cc6e51b9755dbe2845bdb6fb8d3abce0 (patch)
tree52652ad954f4c91e091b17cf329d677130ce07fe
parentb4f5ec676005a01e47ace652ba722f8f1d5d2ec5 (diff)
gnu: Add r-tarchetypes.
* gnu/packages/cran.scm (r-tarchetypes): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6eb5a99343..8c631bdccd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14457,6 +14457,43 @@ equations, and Cox proportional hazards models. Functions are available to
handle data from simple random samples as well as complex surveys.")
(license license:gpl3+)))
+(define-public r-tarchetypes
+ (package
+ (name "r-tarchetypes")
+ (version "0.7.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tarchetypes" version))
+ (sha256
+ (base32
+ "05yhq8xnrpk37x7fq0yjw4m527ji28s16dskfmljrbrzb064nw2g"))))
+ (properties `((upstream-name . "tarchetypes")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-digest
+ r-dplyr
+ r-fs
+ r-furrr
+ r-future
+ r-future-callr
+ r-rlang
+ r-targets
+ r-tibble
+ r-tidyselect
+ r-vctrs
+ r-withr))
+ (home-page "https://docs.ropensci.org/tarchetypes/")
+ (synopsis "Archetypes for Targets")
+ (description
+ "Function-oriented Make-like declarative pipelines for statistics and
+data science are supported in the targets R package. As an extension to
+targets, the tarchetypes package provides convenient user-side functions to
+make targets easier to use. By establishing reusable archetypes for common
+kinds of targets and pipelines, these functions help express complicated
+reproducible pipelines concisely and compactly. The methods in this package
+were influenced by the drake R package by Will Landau (2018)
+<doi:10.21105/joss.00550>.")
+ (license license:expat)))
+
(define-public r-targets
(package
(name "r-targets")