summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-04 14:01:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:57:29 +0300
commitcbfef1f903c9b3e813abd0d1c860a5d52502f897 (patch)
tree31916032ddb72289cc0a3e9dffb1547f1922c759
parentf6a1efbca486f39376582796f0423ea9aa831b39 (diff)
gnu: Add rust-scoped-tls.
* gnu/packages/crates-io.scm (rust-scoped-tls): New variable.
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f9dd78df3b..73bff909a8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -578,6 +578,27 @@ rust-lang/rust integration.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-scoped-tls
+ (package
+ (name "rust-scoped-tls")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "scoped-tls" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hj8lifzvivdb1z02lfnzkshpvk85nkgzxsy2hc0zky9wf894spa"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/alexcrichton/scoped-tls")
+ (synopsis "Rust library providing the old standard library's scoped_thread_local")
+ (description "This crate provides a library implementation of the standard
+library's old @code{scoped_thread_local!} macro for providing scoped access to
+@dfn{thread local storage} (TLS) so any type can be stored into TLS.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-unicode-xid
(package
(name "rust-unicode-xid")