summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-01-03 18:29:24 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-03 20:45:46 +0100
commit05ec287988971b1365a2b7aa8a2c821da4cb1ae9 (patch)
tree71643ae76e6a274337360cd870839a7b6dae8332
parent01d659f530361bb81ef4aa8fceb7479b3ab54b49 (diff)
gnu: Add cl-ana.lorentz.
* gnu/packages/lisp-xyz.scm (sbcl-cl-ana.lorentz, cl-ana.lorentz): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 03a9e27f15..4c3fa0d42a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8454,3 +8454,20 @@ visualization.")
(define-public cl-ana.linear-algebra
(sbcl-package->cl-source-package sbcl-cl-ana.linear-algebra))
+
+(define-public sbcl-cl-ana.lorentz
+ (package
+ (inherit sbcl-cl-ana-boot0)
+ (name "sbcl-cl-ana.lorentz")
+ (inputs
+ `(("cl-ana.generic-math" ,sbcl-cl-ana.generic-math)
+ ("cl-ana.linear-algebra" ,sbcl-cl-ana.linear-algebra)
+ ("cl-ana.tensor" ,sbcl-cl-ana.tensor)
+ ("iterate" ,sbcl-iterate)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments sbcl-cl-ana-boot0)
+ ((#:asd-file _ "") "lorentz/cl-ana.lorentz.asd")
+ ((#:asd-system-name _ #f) "cl-ana.lorentz")))))
+
+(define-public cl-ana.lorentz
+ (sbcl-package->cl-source-package sbcl-cl-ana.lorentz))