summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-03 16:47:03 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-03 16:47:03 -0600
commit2e26dd69c8176a29a0f227b619036e918c5a49d1 (patch)
tree5c8b2edde660debeecedc9431ded2ccda70b6b7a
parenteb1ebabffe8298495bdfbb5011c2d672541d02f3 (diff)
gnu: Add ocaml-fftw3.
* gnu/packages/ocaml.scm (ocaml-fftw3): New variable.
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2e8072cbbe..a9e421a17c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5180,6 +5180,39 @@ advantage over ocamldoc is an accurate cross-referencer, which handles the
complexity of the OCaml module system.")
(license license:isc)))
+(define-public ocaml-fftw3
+ (package
+ (name "ocaml-fftw3")
+ (version "0.8.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Chris00/fftw-ocaml.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l66yagjkwdcib6q55wd8wiap50vi23qiahkghlvm28z7nvbclfk"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-target "tests"))
+ (propagated-inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)))
+ (native-inputs
+ `(("ocaml-cppo" ,ocaml-cppo)
+ ("ocaml-lacaml" ,ocaml-lacaml)))
+ (home-page
+ "https://github.com/Chris00/fftw-ocaml")
+ (synopsis
+ "Bindings to FFTW3")
+ (description
+ "Bindings providing OCaml support for the seminal Fast Fourier Transform
+library FFTW.")
+ (license license:lgpl2.1))) ; with static linking exception.
+
(define-public ocaml-lacaml
(package
(name "ocaml-lacaml")