summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-04 14:51:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-04 22:38:12 +0100
commit3cc6b1232bc5aab709f429100be7b5fc72c17a67 (patch)
treeafee8360a273319208bd7f97b2cba2200aff6105
parent1f6f0b6bca7788411e19ed4187a2ccc57ccc6186 (diff)
gnu: Add attention.
* gnu/packages/opencog.scm (attention): New variable.
-rw-r--r--gnu/packages/opencog.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/opencog.scm b/gnu/packages/opencog.scm
index e969a7e9de..4cde45d9ab 100644
--- a/gnu/packages/opencog.scm
+++ b/gnu/packages/opencog.scm
@@ -152,3 +152,48 @@ features not otherwise available.")
(description "The OpenCog Cogserver is a network and job server for the
OpenCog framework.")
(license license:agpl3))))
+
+(define-public attention
+ ;; There are no releases.
+ (let ((commit "87d43679280ce486cd6757765d2e1df6d502991d")
+ (revision "1"))
+ (package
+ (name "attention")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/opencog/attention.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sndslphicv6w9qpag168rqkxq5sf71l5qbfx6zhsd5bzlf5fhwv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:test-target "tests"
+ #:configure-flags
+ (list
+ (string-append "-DGUILE_INCLUDE_DIR="
+ (assoc-ref %build-inputs "guile")
+ "/include/guile/2.2/")
+ (string-append "-DGUILE_SITE_DIR="
+ (assoc-ref %outputs "out")
+ "/share/guile/site/2.2/"))))
+ (inputs
+ `(("atomspace" ,atomspace)
+ ("boost" ,boost)
+ ("cogserver" ,cogserver)
+ ("cogutil" ,cogutil)
+ ("gmp" ,gmp)
+ ("guile" ,guile-2.2)))
+ (native-inputs
+ `(("cxxtest" ,cxxtest)
+ ("python" ,python-minimal)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/opencog/attention/")
+ (synopsis "OpenCog attention allocation subsystem")
+ (description "Attention Allocation is an OpenCog subsystem meant to
+control the application of processing and memory resources to specific
+tasks.")
+ (license license:agpl3))))