summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaFreniere, Joseph <joseph@lafreniere.xyz>2020-01-03 21:50:25 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-03 22:19:37 -0600
commit4589148f573d4af54295994bc907565603e81525 (patch)
tree24c1d347a17480edd6e7869336c47bcd3ca2d695
parent7eef98484c4eea2ce92fd53a86a001f006a78c16 (diff)
gnu: Add emacs-company-posframe.
* gnu/packages/emacs-xyz.scm (emacs-company-posframe): New variable. Signed-off-by: Brett Gilio <brettg@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3933e8e525..cae6a36858 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3674,6 +3674,35 @@ front-ends. Company comes with many back-ends, e.g. @code{company-elisp}.
These are distributed in separate files and can be used individually.")
(license license:gpl3+)))
+(define-public emacs-company-posframe
+ (let ((version "0.1.0")
+ (revision "1")
+ (commit "67d899502384fb9ab2870aba0af41523dea7b64f"))
+ (package
+ (name "emacs-company-posframe")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumashu/company-posframe.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "051smlvz1siwglsd9k9l0m20mygrx4niflmyshha0064287aysxr"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-posframe" ,emacs-posframe)))
+ (home-page "https://github.com/tumashu/company-posframe")
+ (synopsis "Use a posframe for @code{emacs-company}'s candidate menu")
+ (description
+ "Allows @code{emacs-company} to use child frames for its candidate menus.
+
+@code{emacs-company-posframe} is fast enough for daily use and supports CJK
+languages.")
+ (license license:gpl3+))))
+
(define-public emacs-irony-mode
(package
(name "emacs-irony-mode")