summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-03 20:05:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-04 22:38:12 +0100
commit51c9221a72e56bf08d22fe96be1960ab5818ac65 (patch)
tree9cb86b8074012191c4032fab043203d8c90ca756
parentb224ff4a2d962d0206262cd18cdae8c169e41a0c (diff)
gnu: Add cogutil.
* gnu/packages/opencog.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/opencog.scm62
2 files changed, 64 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0c5a688933..83bba6b644 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -7,7 +7,7 @@
# Copyright © 2016, 2017, 2018 Kei Kebreau <kkebreau@posteo.net>
# Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
# Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
-# Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+# Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
# Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
# Copyright © 2016, 2017, 2018, 2019 Alex Vong <alexvong1995@gmail.com>
# Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -377,6 +377,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/onc-rpc.scm \
%D%/packages/opencl.scm \
%D%/packages/openbox.scm \
+ %D%/packages/opencog.scm \
%D%/packages/openldap.scm \
%D%/packages/openstack.scm \
%D%/packages/orpheus.scm \
diff --git a/gnu/packages/opencog.scm b/gnu/packages/opencog.scm
new file mode 100644
index 0000000000..944174c19b
--- /dev/null
+++ b/gnu/packages/opencog.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages opencog)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix utils))
+
+(define-public cogutil
+ ;; The last release was in 2016. Other OpenCog packages require a later
+ ;; version.
+ (let ((commit "b07b41b2eaf01627c78b27f1f28bb09ef7086f8e")
+ (revision "1"))
+ (package
+ (name "cogutil")
+ (version (git-version "2.0.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/opencog/cogutil.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ymmcrinp0prlxsmxmwdjjl4kgaj7wzq39d5b1q2apgg94yfdhqb"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:test-target "tests"))
+ (inputs
+ `(("boost" ,boost)))
+ (native-inputs
+ `(("cxxtest" ,cxxtest)
+ ("python" ,python-minimal)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/opencog/cogutil/")
+ (synopsis "Low-level C++ programming utilities used by OpenCog components")
+ (description "The OpenCog utilities is a miscellaneous collection of C++
+utilities use for typical programming tasks in multiple OpenCog projects.")
+ ;; Either of these licenses.
+ (license (list license:agpl3 license:asl2.0)))))