summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-01-03 17:23:59 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-03 20:45:44 +0100
commit769015b9d706613dfac5c8ba66e9cba7f0ac938e (patch)
tree4b5c20f7f0c1c734f0f2ea67503fde24ce4df489
parenteac5d1dd4cbd3ac06a1229c3bc6ce9f1e2bb9100 (diff)
gnu: Add cl-ana.hdf-cffi.
* gnu/packages/lisp-xyz.scm (sbcl-cl-ana.hdf-cffi, cl-ana.hdf-cffi, ecl-cl-ana.hdf-cffi): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ebbed9d7cd..32189c5994 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8171,3 +8171,30 @@ visualization.")
(define-public ecl-cl-ana.table-utils
(sbcl-package->ecl-package sbcl-cl-ana.table-utils))
+
+(define-public sbcl-cl-ana.hdf-cffi
+ (package
+ (inherit sbcl-cl-ana-boot0)
+ (name "sbcl-cl-ana.hdf-cffi")
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("hdf5" ,hdf5-parallel-openmpi)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments sbcl-cl-ana-boot0)
+ ((#:asd-file _ "") "hdf-cffi/cl-ana.hdf-cffi.asd")
+ ((#:asd-system-name _ #f) "cl-ana.hdf-cffi")
+ ((#:phases phases '%standard-phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "hdf-cffi/hdf-cffi.lisp"
+ (("/usr/lib/i386-linux-gnu/hdf5/serial/libhdf5.so")
+ (string-append
+ (assoc-ref inputs "hdf5")
+ "/lib/libhdf5.so")))))))))))
+
+(define-public cl-ana.hdf-cffi
+ (sbcl-package->cl-source-package sbcl-cl-ana.hdf-cffi))
+
+(define-public ecl-cl-ana.hdf-cffi
+ (sbcl-package->ecl-package sbcl-cl-ana.hdf-cffi))