summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-04 14:57:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-04 22:38:12 +0100
commit92afa57b9311812fd9e44a90939e0137e2180d11 (patch)
tree6626dd8d3e9bc389c49f5917b47cc08e5beed9a2
parent0d66b9d6cd6894a82871468f0c14071a34def0f2 (diff)
gnu: Add cl-zpb-ttf.
* gnu/packages/lisp-xyz.scm (sbcl-zpb-ttf, ecl-zpb-ttf, cl-zpb-ttf): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 41c2fba0c5..6255af0ded 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
-;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
@@ -371,6 +371,35 @@ ANSI-compliant Common Lisp implementations.")
(define-public cl-unicode
(sbcl-package->cl-source-package sbcl-cl-unicode))
+(define-public sbcl-zpb-ttf
+ (package
+ (name "sbcl-zpb-ttf")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xach/zpb-ttf.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wh66vjijzqlydnrihynpwp6796917xwrh0i9li93c17kyxa74ih"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/xach/zpb-ttf")
+ (synopsis "TrueType font file access for Common Lisp")
+ (description
+ "ZPB-TTF is a TrueType font file parser that provides an interface for
+reading typographic metrics, glyph outlines, and other information from the
+file.")
+ (license license:bsd-2)))
+
+(define-public ecl-zpb-ttf
+ (sbcl-package->ecl-package sbcl-zpb-ttf))
+
+(define-public cl-zpb-ttf
+ (sbcl-package->cl-source-package sbcl-zpb-ttf))
+
(define-public sbcl-clx
(package
(name "sbcl-clx")