summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-03 17:40:38 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-03 17:40:38 -0600
commitbd45235e2cfec7acdd29297f0257a3faa3efea7d (patch)
tree00155cf7d720cac6f164e5530c9cb4e2150e7076
parent2e26dd69c8176a29a0f227b619036e918c5a49d1 (diff)
gnu: emacs-doom-themes: Add note about byte-compilation issue.
* gnu/packages/emacs-xyz.scm (emacs-doom-themes): The byte-compilation issue has been worked around upstream, but arguably not as effective as the strategy we use in our package. Make a note about this issue, and mark the affecting commit number.
-rw-r--r--gnu/packages/emacs-xyz.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 37a34fe236..d9d83b4fbe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19853,6 +19853,10 @@ contrast and few colors.")
;; files. In order to cope with this issue, we disable
;; byte-compilation until this issue is resolved.
;; <https://github.com/hlissner/emacs-doom-themes/issues/314>
+ ;;
+ ;; NOTE: Byte-comp has been disabled in/after commit 9cd6872.
+ ;; However our method of selective disabling is preferential to
+ ;; just widely disabling byte-compilation.
(add-after 'move-themes 'disable-breaking-compilation
(lambda _
(for-each (lambda (file)