summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-03 19:55:47 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-04 23:44:25 +0100
commitf918a8d9d80b9500d5f336c0d872fe06ef48c1e2 (patch)
tree89c7295ee86870f2647e6c554f0ddd69d3ec6b9c
parentd67fa5c824828dd27e3e14427e85e2c3e8160dae (diff)
gnu: guile-hashing: Add variant for Guile 3.0.
* gnu/packages/guile-xyz.scm (guile3.0-hashing): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f720679329..80ff00b23b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
@@ -2791,3 +2791,10 @@ the style of the Node Package Manager (NPM).")
functions in pure R6RS Scheme: CRC, HMAC, MD5, SHA-1, and SHA-2 (SHA-256,
SHA-512).")
(license license:expat)))
+
+(define-public guile3.0-hashing
+ (package
+ (inherit guile-hashing)
+ (name "guile3.0-hashing")
+ (native-inputs
+ `(("guile" ,guile-next)))))