summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:39:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:19:02 +0200
commit0bc890a5cb9153b27c99df8014f679d478cfd3d3 (patch)
tree49f57dd13d3bf57312a7263dbd61fa985d95dc6f
parent6c5f4ab9e9a668bbc649ccc8e2cf7435f9738f2a (diff)
gnu: Add texlive-collection-binextra.
* gnu/packages/tex.scm (texlive-collection-binextra): New variable.
-rw-r--r--gnu/packages/tex.scm122
1 files changed, 122 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 29c5cd1655..91e61b8545 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -89,6 +89,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages plotutils)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
@@ -21981,6 +21982,127 @@ macros, Computer Modern fonts, and configuration for common drivers; no
LaTeX.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-binextra
+ (package
+ (name "texlive-collection-binextra")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list asymptote
+ texlive-a2ping
+ texlive-adhocfilelist
+ texlive-arara
+ texlive-bibtex8
+ texlive-bibtexu
+ texlive-bundledoc
+ texlive-checklistings
+ texlive-chklref
+ texlive-chktex
+ texlive-clojure-pamphlet
+ texlive-cluttex
+ texlive-collection-basic
+ texlive-ctan-o-mat
+ texlive-ctan-chk
+ texlive-ctanbib
+ texlive-ctanify
+ texlive-ctanupload
+ texlive-ctie
+ texlive-cweb
+ texlive-de-macro
+ texlive-detex
+ texlive-digestif
+ texlive-dtl
+ texlive-dtxgen
+ texlive-dvi2tty
+ texlive-dviasm
+ texlive-dvicopy
+ texlive-dvidvi
+ texlive-dviinfox
+ texlive-dviljk
+ texlive-dviout-util
+ texlive-dvipng
+ texlive-dvipos
+ texlive-dvisvgm
+ texlive-findhyph
+ texlive-fragmaster
+ texlive-git-latexdiff
+ texlive-gsftopk
+ texlive-hook-pre-commit-pkg
+ texlive-installfont
+ texlive-ketcindy
+ texlive-lacheck
+ texlive-latex-git-log
+ texlive-latex-papersize
+ texlive-latex2man
+ texlive-latex2nemeth
+ texlive-latexdiff
+ texlive-latexfileversion
+ texlive-latexindent
+ texlive-latexmk
+ texlive-latexpand
+ texlive-light-latex-make
+ texlive-listings-ext
+ texlive-ltxfileinfo
+ texlive-ltximg
+ texlive-luajittex
+ texlive-make4ht
+ texlive-match-parens
+ texlive-mflua
+ texlive-mkjobtexmf
+ texlive-optexcount
+ texlive-patgen
+ texlive-pdfbook2
+ texlive-pdfcrop
+ texlive-pdfjam
+ texlive-pdflatexpicscale
+ texlive-pdftex-quiet
+ texlive-pdftosrc
+ texlive-pdfxup
+ texlive-pfarrei
+ texlive-pkfix
+ texlive-pkfix-helper
+ texlive-purifyeps
+ texlive-pythontex
+ texlive-seetexk
+ texlive-spix
+ texlive-srcredact
+ texlive-sty2dtx
+ texlive-synctex
+ texlive-tex4ebook
+ texlive-texaccents
+ texlive-texcount
+ texlive-texdef
+ texlive-texdiff
+ texlive-texdirflatten
+ texlive-texdoc
+ texlive-texdoctk
+ texlive-texfot
+ texlive-texliveonfly
+ texlive-texloganalyser
+ texlive-texlogfilter
+ texlive-texlogsieve
+ texlive-texosquery
+ texlive-texplate
+ texlive-texware
+ texlive-tie
+ texlive-tlcockpit
+ texlive-tpic2pdftex
+ texlive-typeoutfileinfo
+ texlive-upmendex
+ texlive-web
+ texlive-xindex
+ texlive-xindy
+ texlive-xpdfopen))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "TeX auxiliary programs")
+ (description
+ "This package provides a myriad of additional TeX-related support
+programs. It includes programs and macros for DVI file manipulation, literate
+programming, patgen, and plenty more.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-collection-context
(package
(name "texlive-collection-context")