summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <phfrohring@deeplinks.com>2023-12-10 14:04:04 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-17 22:22:31 +0100
commit2060e3f5c8130bb9214a6951ac32475811963061 (patch)
treecb377e1dfe224239fe90c72fe5c1d1ffe46a00ca
parentab74b47e92fd88ebcef20cec2600d690a6061c23 (diff)
gnu: Add elixir-excoveralls.
* gnu/packages/elixir-xyz.scm (elixir-excoveralls): New variable. Change-Id: Ib271d8a7393e21178806df28ab892afe99757297 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/elixir-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index ef80c9550c..14e67060e8 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -182,6 +182,28 @@ an up-to-date CA certificate store file for Elixir applications.")
(home-page "https://hexdocs.pm/castore/")
(license license:asl2.0)))
+(define-public elixir-excoveralls
+ (package
+ (name "elixir-excoveralls")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri name version))
+ (sha256
+ (base32 "02x69ll5scvraky0k5gacvnnmldv5k04kgk02x087d9w3y8vn28i"))))
+ (build-system mix-build-system)
+ (propagated-inputs (list elixir-castore elixir-jason))
+ (arguments (list #:tests? #f)) ; no tests
+ (synopsis "Coverage report tool with coveralls.io integration")
+ (description
+ "Library that reports test coverage statistics, with the option to
+post to coveralls.io service. It uses Erlang's cover to generate coverage
+information, and posts the test coverage results to coveralls.io through the
+JSON API.")
+ (home-page "https://hexdocs.pm/excoveralls/")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar